Problem

SmartChk Tablet hat kein automatisches Popup zum Aktualisieren auf eine neuere Version der Software erhalten.

Ursache

Es kann mehrere Gründe geben, aufgrund derer das Tablet nicht das neueste Softwareupdate erhalten hat.

  1. Das Tablet wurde nicht ordnungsgemäß neu gestartet.
  2. Der öffentliche Schlüssel für das Tablet ist auf dem Update-Server nicht vorhanden.
  3. Wifi oder Internetverbindung, die vom Tablet verwendet werden, erlauben keine Verbindung mit dem Update-Server.


Lösung

  1. Beginnen Sie mit der Empfehlung an den Mitarbeiter, das Tablet zurückzusetzen, indem Sie den Netzschalter gedrückt halten, bis das Tablet neu gestartet wird (ca. 20 Sekunden). Melden Sie sich beim Neustart über den Smartchk-Benutzer an und stellen Sie sicher, dass das Tablet über eine stabile WLAN-Verbindung verfügt. Überprüfen Sie, ob das Update verfügbar ist, und klicken Sie auf die Option, um den Vorgang zu starten. Sobald das Update abgeschlossen ist, wird das Tablet neu gestartet und es dauert 3-5 Minuten, bis die Installation der Pakete abgeschlossen ist. Nach erfolgreichem Abschluss des Updates erhalten Sie eine Nachricht, dass das Tablet auf die Version X.X.X aktualisiert wurde. Klicken Sie auf OK, um zu bestätigen und fortzufahren.
  2. Der Smartchk-Agent muss den öffentlichen Schlüssel auf dem Update-Server hochladen. Starten Sie das Tablet neu und prüfen Sie, ob das Update auf der Standort-Seite angezeigt wird. Klicken Sie auf Herunterladen und installieren, um die Software zu aktualisieren.
  3. In diesem Fall erkennt der smartchk-Agent, dass der öffentliche Schlüssel des Tablets auf dem Update-Server vorhanden ist und das Tablet keine Verbindung zum Server herstellen kann. Der einfachste Weg besteht darin, dem Vertreter zu empfehlen, die WLAN-Verbindung zu wechseln. Andernfalls versuchen Sie das USB-Tethering mit einem Mobiltelefon mit einem aktiven Datentarif. Starten Sie das Tablet neu und prüfen Sie, ob das Update angezeigt wird.



Linux Befehle für die manuelle Aktualisierung

  • Um die Softwareversion des Tablets zu überprüfen

          # cd /home/smartchk/POS20

          # cat version

  • Um die SFTP-Verbindung zu überprüfen

           # sftp xcaliber@updatesatt.smartchk.net


Wenn Sie eine Fehlermeldung erhalten "permission denied" ist der öffentliche Schlüssel nicht auf dem Update-Server vorhanden

Wenn die Verbindung erfolgreich ist, können Sie die Software aktualisieren.


  •  Um die Software manuell zu aktualisieren

          # cd /opt/admin/scripts/POS/scripts

          # bash sc_KInstallwrapper.sh

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