Created | Updated | Affects version | Fix version |
---|---|---|---|
|
| Mobile Diagnostics and Erasure 4.0.2 | Mobile Diagnostics and Erasure 4.1.0 |
Problem
The erasure of android devices running Android 10 fails after a few seconds of starting.
Cause
Changes implemented into Android 10 have resulted in several of the automated steps which are normally completed by the erasure app now requiring manual confirmation on the device.
Solution
Carry out the below detailed manual steps to allow the erasure app to run on Android 10 devices.
1. When the Choose what to allow WipeAdmin to access permissions screen is shown on the device please tap Continue straight away to avoid the erasure failing, if the erasure app attempts to obtain permission automatically three times and fails the erasure will be classed as failed.
2. When prompted to Set WipeAdmin as your default SMS app? please select the radial button next to WipeAdmin option and tap Set as default.
3. Lastly when the below message stating "This app was built for an older version of Android and may not work properly. Try checking for updates or contact the developer." is shown please tap OK to continue.
The erasure should now be performed as normal on the device.
Update 08.11.2019:
With the release of BMDE 4.1.0 it is no longer necessary to manually action these steps, if you are encountering this issue please update to version 4.1.0 or newer.