Created dateUpdated dateAffects versionFix version

 


Mobile Diagnostics and Eraser - all versionsN/A

Problem

When performing diagnostic's on an Android device the installation of the diagnostic application fails the first time, requiring a second attempt before the application installs successfully.

Cause

When the device's screen lock activates prior to the application being installed it's not possible to install the diagnostic application successfully until the device has been unlocked.

Resolution

Disable/extended the devices automatic screen lock to avoid device becoming locked prior to the application being installed.


Generic steps for disabling/extending the automatic screen lock

  1. Access settings → Security
  2. Locate the Automatically lock option
  3. Disable if the option is available, if not extended the timer to the maximum available duration