Problem
Updating to or installing Mobile Diagnostics and Erasure version 3.3.1 or newer the connection to Blancco Cloud is not possible.
Cause
As of version 3.3.1, the Mobile Diagnostics and Erasure software validates the HTTPS Certificate against external servers and Blancco Cloud to ensure a secure network connection
Resolution
Check that the date set within the Mobile Diagnostics and Erasure software is set correctly if the date isn't correctly set the certificate validation will fail to result in the communication with Blancco Cloud failing.
To set the date in Mobile Diagnostics and Erasure
- At the Mobile Device, Eraser login page click the settings button at the bottom of the screen
- Click Set Time and Date
- Adjust the displayed date to the current date and click Ok to apply