Created dateUpdated dateAffects versionFix version

 

  

Drive Eraser - All versionsN/A

Description

Below instructions go through the necessary steps to create a bootable Blancco USB drive while using MacOS.

Note that the USB flash drive is not recognized by Windows due to USB format type after completing this process.

Step by step instructions

  1. Open the Terminal (in /Applications/Utilities/ or query Terminal in Spotlight)
  2. Convert Drive Eraser ISO to .img format using the convert option of hdiutil

    hdiutil convert -format UDRW -o /path/to/target.img /path/to/source.iso
  3. MacOS tends to put the .dmg ending on the output file automatically. Rename the file to remove this additional extension.

    mv /Users/blancco/Desktop/Drive_Eraser.img.dmg /Users/blancco/Desktop/DriveEraser.img
  4. Use diskutil to identify the USB flash drive
    1. Type diskutil list Press ENTER, used to get the current list of devices
    2. Insert desired USB flash drive
    3. Type diskutil list Press ENTER
      1. Use diskutil to determine the device node assigned to inserted flash drive (e.g. /dev/disk2)
      2. Take note of new device node ID, as this will be the newly added device inserted.
  5. Unmount the USB flash drive (replace N with the disk number from the last command - in the previous example, N would be 2)

    diskutil unmountDisk /dev/diskN
  6. Convert and copy the image file to the USB flash drive (replace /path/to/target.img with the path where the Drive Eraser .img file is located). Running the command requires user password, when prompted provide the password and press ENTER to continue.

    sudo dd if=/path/to/DriveEraser.img of=/dev/rdiskN bs=1m

    If you see the error dd: Invalid number '1m', you are using GNU dd. Use the same command but replace bs=1m with bs=1M.

    If you see the error dd: /dev/diskN: Resource busy, make sure the disk is not in use. Start the 'Disk Utility.app' and unmount (don't eject) the drive.

  7. Copying the IMG to the USB flash drive in progress. Note that there is no status provided during the copying process.
  8. When completed, MacOS should ask to eject USB. If not asked to eject, run the following command and remove your flash media when the command completes.

    diskutil eject /dev/diskN