ErstellungsdatumAktualisierungsdateumBetroffenen VersionenGefixte Versionen

 


Management Console - Alle VersionenN/A

Problem

Das Upgrade/Update der Management Console schlägt nach dem Abschluss der "Paketinstallation" auf dem Klick auf "Weiter" fehl. Nachfolgende Versuche die Management Console zu aktualisieren schlagen auch nach dem Wiederherstellen einer Sicherung der Management Console Installation fehl.

Ursache

Wenn nach der Installation der Pakete auf Weiter geklickt wird, werden Änderungen auf die Datenbank angewendet um alle neuen Felder, Werte oder Änderungen aufzunehmen die im Rahmen des Upgrades/Updates erforderlich sind. In diesem Fall setzt die Installation eine Sperre für die Datenbank. Alle zusätzlichen Versuche schlagen aufgrund der bereits vorhandenen Sperre fehl. Dies kann in der Datei install.log (unter "Programme\Blancco\Blancco Management Console\logs") geprüft werden. Bitte beachten Sie, dass dies der Standardspeicherort ist und sich auf Ihrem System unterscheiden kann. Folgender Fehler wird im Log angezeigt:


Could not acquire change log lock. Currently locked by Computer\User since DD/MM/YY hh:mm


Der Computer zeigt das verwendete System und das Benutzerkonto an das zum Zeitpunkt der Sperre verwendet wurde.

Lösung

Wenn vor dem ersten Versuch das Upgrade/Update durchzuführen, eine Sicherung der Datenbank erstellt wurde, wird die Sperre aufgehoben. Wenn jedoch keine Sicherung verfügbar ist oder der erste fehlgeschlagene Versuch vor der Sicherung durchgeführt wurde, muss die Sperre manuell aus der Datenbank entfernt werden.

In den folgenden Schritten wird der Prozess sowohl für eine MS SQL-Datenbank als auch für eine PostgreSQL-Datenbank detailliert beschrieben. Nach Abschluss dieser Schritte sollte es möglich sein, das Upgrade/Update der Management Console abzuschließen, solange die Ursache für den ursprünglichen Fehler vorliegt gelöst wurde.



Microsoft SQL Datenbank unter Verwendung des SQL Server Management Studio 

  1. Melden Sie sich bei SQL Server Management Studio an und erweitern Sie den Ordner "Datenbanken"
  2. Suchen Sie die Blancco-Berichtsdatenbank und erweitern Sie die Datenbank (wenn Sie sich nicht sicher sind, welchen Namen die verwendete Datenbank hat, finden Sie diese in der Datei main.properties am folgenden Speicherort "Program Files\Blancco\Blancco Management Console\apache-tomcat\webapps\ROOT\WEB-INF\classes". Bitte beachten Sie, dass dies der Standardspeicherort ist und der Speicherort auf Ihrem System unterscheiden kann. In der Datei main.properties finden Sie den Eintrag "database.url =". Der Wert dieses Eintrags enthält "database.name =", dies ist die Datenbank die von der Management Console-Software verwendet wird. ")
  3. Suchen Sie den Ordner "Tabellen" und erweitern Sie ihn, um die Datenbanktabellen anzuzeigen
  4. Suchen Sie die Tabelle dbo.DATABASECHANGELOGLOCK und klicken Sie mit der rechten Maustaste, um das Optionsmenü anzuzeigen
  5. Wählen Sie "Die ersten 200 Zeilen bearbeiten" um den Inhalt der Tabelle anzuzeigen
  6. Suchen Sie die Spalte in der LOCKED auf True gesetzt ist. Die Werte der Spalten LOCKGRANTED (zeigt an, wann die Sperre wirksam wurde) und LOCKEDBY (zeigt das System/den Benutzer an, der die Datenbank gesperrt hat) müssen in der gelöscht werden um die Sperre aufzuheben.

PostgreSQL database unter Verwendung des pgAdmin Tool

  1. Öffnen Sie pgAdmin, erweitern Sie "Server" und erweitern Sie dann die korrekte PostgreSQL-Installation/-Instanz
  2. Erweitern Sie "Datenbanken", suchen und erweitern Sie die mit der Management Console verwendete Datenbank (wenn Sie sich nicht sicher sind, welchen Namen die verwendete Datenbank hat, finden Sie diese in der Datei main.properties am folgenden Speicherort "Program Files\Blancco\Blancco Management Console\apache-tomcat\webapps\ROOT\WEB-INF\classes". Bitte beachten Sie, dass dies der Standardspeicherort ist und der Speicherort auf Ihrem System unterscheiden kann. In der Datei main.properties finden Sie den Eintrag "database.url =". Der Wert dieses Eintrags enthält "database.name =", dies ist die Datenbank die von der Management Console-Software verwendet wird. ")
  3. Erweitern Sie "Schemas" → "public", suchen Sie den Ordner "Tables" und erweitern Sie ihn, um die Datenbanktabellen anzuzeigen
  4. Suchen Sie das "databasechangeloglock" und klicken Sie mit der rechten Maustaste, um das Optionsmenü anzuzeigen
  5. Wählen Sie "Daten anzeigen/bearbeiten" → "Erste 100 Zeilen", um den Inhalt der Tabelle anzuzeigen
  6. Suchen Sie die Spalte in der LOCKED auf True gesetzt ist. Die Werte der Spalten LOCKGRANTED (zeigt an, wann die Sperre wirksam wurde) und LOCKEDBY (zeigt das System/den Benutzer an, der die Datenbank gesperrt hat) müssen in der gelöscht werden um die Sperre aufzuheben.