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Management Console - All versionsN/A

Problem

When performing the upgrade/update of the Management Console the process fails after clicking next once the "Package installation" has completed

Subsequent attempts to upgrade/update the Management Console continue to fail at the same point even after restoring a backup of the Management Console installation directory.

Cause

問題事象

Management Console のアップグレード/アップデート実行時「パッケージのインストール」完了後に「次へ」をクリックした際にプロセスが失敗すると、その後たとえバックアップからManagement Consoleインストールディレクトリをリストアしてもアップグレード/アップデート再試行は同箇所で必ず失敗する。

原因

パッケージのインストール後に「次へ」をクリックすると、アップグレード/アップデートの一環として必要な新しいフィールド、値、その他の変更がデータベースに適用されます。変更のためにインストールプロセスはデータベースをロックしますが、ロック後にアップグレード/アップデートが失敗した場合、先行するロックにより後続の再試行も失敗します。これはinstall.logファイル(デフォルトでは「Program When clicking Next after the installation of the packages, changes are applied to the database to include any new fields, values, or changes which are required as part of the upgrade/update. For this to happen the installation sets a lock on the database if the upgrade/update fails after this has been applied all additional attempts will fail due to the lock already existing. This can be confirmed from the install.log file (found "Program Files\Blancco\Blancco Management Console\logs" please note this is the default location and may differ on your system) by the existence of the following errorlogs」にあります。環境により異なる可能性があります)にある次のメッセージから確認できます:


Code Block
Could not acquire change log lock. Currently locked by Computer\User since DD/MM/YY hh:mm

The computer will show the system being used and User the account being used at the time the lock was set.

Resolution

If a backup of the database was taken prior to the first attempt to perform the upgrade/update restoring the backup will clear the lock, however, if no backup is available or the first failed attempt was made before the backup was taken the lock will need to be removed manually from the database.


使用されているシステムとおよびロック時に使用されていたユーザーアカウントが表示されます。

解決策

最初のアップグレード/アップデート実行前にデータベースのバックアップを取得している場合には、リストアによりロックはクリアされます。一方、バックアップが使用できない、またはバックアップ取得前に失敗してしまった場合には、データベースロックを手動で解除する必要があります。

以下の手順詳細をご参照ください。MS SQL データベースおよびPostgreSQLデータベースの双方について説明しています。この手順が完了し、また最初に失敗した原因を解決すれば、Management Console のアップグレード/アップデートインストールを完了できます。Please see the instructions below which detail the process for both an MS SQL database and a PostgreSQL database, once these steps have been completed it should be possible to complete the upgrade/update of the Management Console installation as long as the cause for the original failure has been resolved.



UI Tabs
UI Tab
titleMicrosoft SQL database using the SQL Server Management Studio

Microsoft SQL database using the SQL Server Management StudioStudioを使用したMicrosoft SQLデータベース 

  1. Login into the SQL Server Management Studio and expand the Databases folderStudioにログインしデータベースフォルダを展開
  2. Blanccoレポートデータベースを展開(使用されているデータベース名が不明な場合、main.propertiesファイルから確認できます。このファイルは次の場所にあります「Program Locate the Blancco reports database and expand the database (if you are unsure of the name of the database being used this can be found from the main.properties file in the following location "Program Files\Blancco\Blancco Management Console\apache-tomcat\webapps\ROOT\WEB-INF\classes" please note this is the default location and the location may differ on your system. In the main.properties file you will find the entry "database.url=" the value of this entry will include "database.name=" this is the database being used by the Management Console software")
  3.  Locate the Tables folder and expand it to display the database tables
  4. Locate the dbo.DATABASECHANGELOGLOCK and right-click to display the options menu
  5. Select Edit Top 200 rows which will display the content of the table
  6. classes」。これはデフォルトの場所であり、システムによって異なる場合があります。main.propertiesファイル内に「database.url=」エントリーがあり、さらにその値に「database.name=」が含まれています。これがManagement Consoleに使用されているデータベースです)
  7.  「テーブル」フォルダーを展開しデータベーステーブルを表示
  8. dbo.DATABASECHANGELOGLOCKを選択し右クリックからオプションメニューを表示
  9. 「上位200行を編集」を選択しテーブルの内容を表示
  10. 「LOCKED」列が「True」かつ「LOCKGRANTED」列(ロックがいつ有効になったかを示す)および「LOCKEDBY」列(データベースをロックしたシステム/ユーザーを示す)に値が入力されている行を見つけ、ロックを解除するためにこれらの行を削除You will see a row which has the LOCKED column set to True and values entered into the LOCKGRANTED (indicating when the lock was put into effect) and LOCKEDBY (indicating the system/user which locked the database) columns, you will need to delete this row to remove the lock.
UI Tab
titlePostgreSQL database using the pgAdmin tool

PostgreSQL database using the pgAdmin tooltoolを使用したPostgreSQLデータベース

  1. pgAdminを開き「サーバ」を展開しさらに適切なPostgreSQLインストール/インスタンスを展開
  2. 「データベース」を展開、さらにManagement Consoleが使用しているデータベースを展開(使用されているデータベース名が不明な場合、main.propertiesファイルから確認できます。このファイルは次の場所にあります「Program
  3. Open pgAdmin, expand "Servers" and then expand correct PostgreSQL installation/instance
  4. Expand "Databases", then locate and expand the database used with the Management Console and expand the database (if you are unsure of the name of the database being used this can be found from the main.properties file in the following location "Program Files\Blancco\Blancco Management Console\apache-tomcat\webapps\ROOT\WEB-INF\classes" please note this is the default location and the location may differ on your system. In the main.properties file you will find the entry "database.url=" the value of this entry will include "database.name=" this is the database being used by the Management Console software")
  5. Expand "Schemas" → "public" and locate the "Tables" folder and expand it to display the database tables
  6. Locate the "databasechangeloglock" and right-click to display the options menu
  7. Select "View/Edit Data" → "First 100 Rows" which will display the content of the table
  8. classes」。これはデフォルトの場所であり、システムによって異なる場合があります。main.propertiesファイル内に「database.url=」エントリーがあり、さらにその値に「database.name=」が含まれています。これがManagement Consoleに使用されているデータベースです)
  9. 「スキーマ」を展開→「public」および「テーブル」フォルダーを展開しデータベーステーブルを表示
  10. 「databasechangeloglock」を選択し右クリックからオプションメニューを表示
  11. 「データビュー」→ 「先頭100行の表示」を選択しテーブルの内容を表示
  12. 「locked」列が「true」かつ「lockgranted」列(ロックがいつ有効になったかを示す)および「lockedby」列(データベースをロックしたシステム/ユーザーを示す)に値が入力されている行を見つけ、ロックを解除するためにこれらの行を削除You will see a row which has the "locked" column set to "true" and values entered into the lockgranted (indicating when the lock was put into effect) and lockedby (indicating the system/user which locked the database) columns, you will need to delete this row to remove the lock.