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Created date作成日Updated date | 更新日 | Affects version影響を受けるバージョンFix version | 修正バージョン |
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| Management Console - All versions全バージョン | N/A |
Problem
When performing the upgrade/update of the Management Console the process fails after clicking next once the "Package installation" has completed
Subsequent attempts to upgrade/update the Management Console continue to fail at the same point even after restoring a backup of the Management Console installation directory.
Cause
問題事象
Management Console のアップグレード/アップデート実行時「パッケージのインストール」完了後に「次へ」をクリックした際にプロセスが失敗すると、その後たとえバックアップからManagement Consoleインストールディレクトリをリストアしてもアップグレード/アップデート再試行は同箇所で必ず失敗する。
原因
パッケージのインストール後に「次へ」をクリックすると、アップグレード/アップデートの一環として必要な新しいフィールド、値、その他の変更がデータベースに適用されます。変更のためにインストールプロセスはデータベースをロックしますが、ロック後にアップグレード/アップデートが失敗した場合、先行するロックにより後続の再試行も失敗します。これはinstall.logファイル (デフォルトの場所は「Program When clicking Next after the installation of the packages, changes are applied to the database to include any new fields, values, or changes which are required as part of the upgrade/update. For this to happen the installation sets a lock on the database if the upgrade/update fails after this has been applied all additional attempts will fail due to the lock already existing. This can be confirmed from the install.log file (found "Program Files\Blancco\Blancco Management Console\logs" please note this is the default location and may differ on your system) by the existence of the following errorlogs」ですが環境によって異なります) 内の次のメッセージから確認できます:
Code Block |
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Could not acquire change log lock. Currently locked by Computer\User since DD/MM/YY hh:mm |
The computer will show the system being used and User the account being used at the time the lock was set.
Resolution
If a backup of the database was taken prior to the first attempt to perform the upgrade/update restoring the backup will clear the lock, however, if no backup is available or the first failed attempt was made before the backup was taken the lock will need to be removed manually from the database.
使用されているシステムとロック時に使用されていたユーザーアカウントが表示されます。
解決策
最初のアップグレード/アップデート実行前にデータベースのバックアップを取得している場合には、リストアによりロックはクリアされます。一方、バックアップが使用できない、またはバックアップ取得前に失敗してしまった場合には、データベースロックを手動で解除する必要があります。
以下の手順詳細をご参照ください。MS SQLデータベースおよびPostgreSQLデータベースの双方について説明しています。この手順が完了し、また最初に失敗した原因を解決すれば、Management Console のアップグレード/アップデートインストールを完了できます。Please see the instructions below which detail the process for both an MS SQL database and a PostgreSQL database, once these steps have been completed it should be possible to complete the upgrade/update of the Management Console installation as long as the cause for the original failure has been resolved.
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