Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Created date作成日Updated date更新日Affects version影響を受けるバージョンFix version修正バージョン

 

 

Drive Eraser - All versions全バージョンN/A

Description

Below instructions go through the necessary steps to create a bootable Blancco USB drive while using MacOS.

Note that the USB flash drive is not recognized by Windows due to USB format type after completing this process.

Step by step instructions

説明

以下はMacOSを使用して起動可能なBlancco USBドライブを作成するために必要な手順です。

なお、この手順を完了すると、USBフォーマットの種類によりUSBフラッシュドライブがWindows OSで認識されなくなることに注意してください。

作成手順

  1. ターミナルを開きます (「/アプリケーション/ユーティリティ/」フォルダにあります。 あるいはスポットライトでターミナルを検索します) 。
  2. hdiutilコマンドのconvertオプションを使用して、Drive EraserのISOを.img形式に変換します。

  3. Open the Terminal (in /Applications/Utilities/ or query Terminal in Spotlight)
  4. Convert Drive Eraser ISO to .img format using the convert option of hdiutil

    Code Block
    hdiutil convert -format UDRW -o /path/to/target.img /path/to/source.iso
  5. MacOS tends to put the .dmg ending on the output file automatically. Rename the file to remove this additional extension.MacOSが出力ファイルの末尾に.dmgを自動的に追加する場合があります。ファイル名を変更して、この追加された拡張子を削除します。

    Code Block
    mv /Users/blancco/Desktop/Drive_Eraser.img.dmg /Users/blancco/Desktop/DriveEraser.img
  6. Use diskutil to identify the USB flash drive
    1. Type diskutil list Press ENTER, used to get the current list of devices
    2. Insert desired USB flash drive
    3. Type diskutil list Press ENTER
      1. Use diskutil to determine the device node assigned to inserted flash drive (e.g. /dev/disk2)
      2. Take note of new device node ID, as this will be the newly added device inserted.
  7. diskutilコマンドを使用してUSBフラッシュドライブを特定します。
    1. diskutil list と入力し、ENTERキーを押して、現在のデバイスのリストを取得します。
    2. USBフラッシュドライブを接続します。
    3. diskutil list と入力し、ENTERキーを押します。 
      1. diskutilコマンドを使用して、接続したフラッシュドライブに割り当てられたデバイスのノードIDを確認します(例: /dev/disk2)
      2. 新規に接続したデバイスのノードIDが追加されて表示されるので、これを書き留めます
  8. USBフラッシュドライブをアンマウントします(Nはコマンドで得られたディスクの番号に置き換えます - 前の例では、は になります)。Unmount the USB flash drive (replace N with the disk number from the last command - in the previous example, N would be 2)

    Code Block
    diskutil unmountDisk /dev/diskN
  9. Convert and copy the image file to the USB flash drive (replace イメージファイルを変換してUSBフラッシュドライブにコピーします(/path/to/target.img with the path where the Drive Eraser .img file is located). Running the command requires user password, when prompted provide the password and press ENTER to continue.はDrive Eraserの.imgファイルが配置されている実際のパス名に置き換えてください)。コマンドを実行するにはユーザーのパスワードが必要です。プロンプトが表示されたらパスワードを入力し、Enterキーを押して続行します。

    Code Block
    sudo dd if=/path/to/DriveEraser.img of=/dev/rdiskN bs=1m
    Info

    If you see the error dd: Invalid number '1m' , you are using GNU dd. Use the same command but replace bs=1m with bs=1M.というエラーが表示された場合は、GNU のddコマンドを使用しています。同じコマンドで、bs=1m を bs=1Mに置き換えて実行してください。

    If you see the error dd: /dev/diskN: Resource busy , make sure the disk is not in use. Start the 'Disk Utility.app' and unmount (don't eject) the drive.

  10. Copying the IMG to the USB flash drive in progress. Note that there is no status provided during the copying process.
  11. というエラーが表示された場合は、ディスクが使用中でないことを確認します。「ディスクユーティリティ.app 」を起動して、ドライブをアンマウントしますイジェクトはしないでください)。

  12. MGファイルがUSBフラッシュドライブにコピーされます。コピー処理中にはステータスが表示されないことに注意してください。
  13. 処理が完了すると、MacOSがUSBドライブを取り出すように要求します。取り出しを要求されない場合は、次のコマンドを実行し、コマンドが完了したらUSBドライブを取り出します。When completed, MacOS should ask to eject USB. If not asked to eject, run the following command and remove your flash media when the command completes.

    Code Block
    diskutil eject /dev/diskN

...