Created date | Updated date | Affects version | Fix version |
---|---|---|---|
|
| Mobile Diagnostics and Erasure - 3.9 (or newer) | N/A |
Problem
Running certain diagnostic tests on a working mobile device fail and screen may show defects and the audio crackles during the diagnostic tests even though there are not actual issues present.
In case the user runs the tests again these issues are not present anymore and tests complete successfully.
Cause
Such behavior can be caused when the "Run dummy tests" option is enabled under Settings→ Diagnostics-tab. When enabled, the software will include "dummy" tests for the screen and speakers during the diagnostics of the device imitating a defect in the device.
This feature is designed to test the operator accuracy and attention to detail when processing larger quantities of devices.
Resolution
If the operator missed the dummy test causing the diagnostics tests to fail overall it is possible to run the diagnostics again to make sure there is no actual issues with the device.
In case the dummy test are occurring too often, it is possible to define and decrease the interval at which the dummy tests are being run. By default a dummy test is being run after every 100 diagnostics tests.