作成日更新日影響を受けるバージョン修正バージョン

 

 

Mobile Diagnostics and ErasureN/A

問題事象

パッケージのアンインストール失敗が原因でAndroidデバイスの消去が失敗する場合、消去を継続させるためにパッケージをホワイトリスト登録できます。

しかし、ホワイトリスト登録を行って対象デバイスの消去が成功したとしても、追加情報に次のメッセージが出力されてしまいます:

ホワイトリスト登録済の次のパッケージをアンインストールできませんでした:[パッケージ名] そのため、消去の成功を保証できません。詳しくはBlancco社にお問い合わせください。

原因

このメッセージはAndroid OSに組み込まれた特定のアプリケーションが原因で出力されます。多くの場合、OEM/製造元が実装したパッケージ等です。このようなパッケージはアンインストールできません。デバイスを処理するため、これらパッケージをホワイトリスト登録できます。パッケージをホワイトリスト登録すれば、アンインストールに失敗しても消去プロセスは失敗しません。

ホワイトリスト登録されたパッケージのアンインストールに失敗した後もデータ消去が継続して完了した場合、Blanccoは消去が完全に成功しているかを保証できません。 

デフォルトでは、BMDEに管理者アクセスできるユーザーのみパッケージをホワイトリスト登録できます。現在ホワイトリスト登録されているパッケージは「設定」→「Android」タブで参照できます。

解決策

この問題を解決するオプションは以下いずれかです:

  1. 処理の初めにファクトリーリセットを実施すれば、問題のパッケージを削除できる可能性があります。この場合ファクトリーリセット後にデバイスは正常に消去され、ホワイトリストパッケージに関するメッセージはレポートに追記されません。ファクトリーリセットを実施する場合、USBデバッグを再度有効化する必要がある点にご注意ください。
  2. オプション1でパッケージを削除できない場合、残るオプションはホワイトリスト登録のみです。

ファクトリーリセット実施は既存のワークフローに組み込むことも可能です。必要な場合にのみファクトリーリセットを実施し、必要のないデバイスには実施しないよう条件文を定義できます。また、消去前に常に実行するよう設定の有効化も可能です。以下のスクリーンショットにある「設定」→「Androidの設定」→「ファクトリーリセットを消去開始時に必ず実行」から有効化できます。