You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 13 Next »

Cause:

The flash-loader which is extracted from the firmware file, is sent to the phone prior to flashing, fails to reboot the device. The structure of the flash-loader has likely changed due to iOS 12.1.

Resolutions:

Blancco resolution:  3.8.4 due out Dec 11th, plans to include a Factory Reset option included in the workflow, which places the phone in a boot mode Blancco can recognize.

Apple resolution:  Apple is planning to address the issue in 12.1.x, due out on Dec 11th.

Workarounds:

Option 1: Disconnect and connect device a couple of times during the erasure.

  • The cable needs to be reconnected from the device's side.
  • First re-connect might be needed right after download finishes and erasure gets started. After erasure is restarted user should be prepared to reconnect the device quickly again when the progress gets to 7%.
  • From there erasure should continue automatically and is expected to finish ok.

Recommendations:

Due to the impact of frequent changes from Apple, it is recommended to set the iOS firmware download settings to ‘disable’ automatic download.  More information on available settings can be found here.

Update Nov 28, 2018:

Apple has stopped signing iOS 12.0.1 firmware files, so it is required to use iOS 12.1.

To make sure that Blancco Mobile Device Eraser downloads and uses the latest iOS 12.1 which is signed, Apple version information needs to be downloaded from the Apple servers.

Follow the instructions mentioned below in order to manage the source for the Apple version information.

  1. Navigate to Login Screen > Settings > Synchronization Service.
    1. If Synchronization Service is disabled you should only see a dropdown menu to select "version.xml source".
    2. If Synchronization Service is enabled, you can manage this settings from your "server" machine, under the "Firmware DL Settings".
  2. Make sure to select "Apple" as an version.xml source

It is required to manually update the information from the Apple servers after changing the source:

  1. Login to the system
  2. Go to Settings > iOS > Update Apple firmware version information manually > click "Update now"

After these steps you can process iOS devices by following the workaround option 1 described previously in this article.

Update Nov 9, 2018:

Mobile Device Eraser 3.8.3 version released to improve the behavior with this issue. This version will point the software to load iOS 12.0.1 until Apple provides an updated version of the firmware. See the release notes here: Blancco Mobile Device Eraser 3.8.3 is now released!

In BMDE 3.8.3 user can define the source from where to download the Apple version information. This can be controlled from Login Screen > Settings > Synchronization Service.

If Synchronization Service is disabled you should only see a dropdown menu to select "version.xml source". If Synchronization Service is enabled, you can manage this settings from your "server" machine, under the "Firmware DL Settings".

Note! This setting only defines from where the version information is downloaded when the version information is being updated. Changing this setting alone will not re-download the version information from the new source automatically.

To update the version information to selected source, you need to:

  1. Login to the system
  2. Go to Settings > iOS > Update Apple firmware version information manually > click "Update now"

Update Nov 6, 2018:

The root cause is currently identified as an issue with USB interfaces introduced by iOS 12.1. As the issue originating from the Apple firmware, also the fix for this behavior should be provided by Apple. Workaround mentioned above can be used to process these devices for now.




  • No labels