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Mobile Diagnostics and ErasureN/A

Problem

Wenn die Löschung eines Android-Geräts fehlschlägt, weil ein oder mehrere Pakete nicht deinstalliert werden können, können diese Pakete auf eine Whitelist gesetzt werden, um die Löschung auf einem Gerät durchzuführen. 

Nach erfolgreicher Löschung eines Geräts auf dem BMDE wird die folgende Meldung als zusätzliche Information zur Löschung angezeigt:

Deinstallation von Paketen auf der Whitelist fehlgeschlagen. Blancco kann nicht garantieren, dass das Gerät erfolgreich gelöscht wurde. Bitte kontaktieren Sie Ihren Blancco-Vertreter für weitere Informationen. Pakete: [LISTE DER PAKETE AUF DER WHITELIST HIER]. 

Ursache

Diese Informationsmeldung wird durch bestimmte Anwendungen verursacht, die in das Android-Betriebssystem integriert sind. Häufig handelt es sich dabei um vom OEM/Hersteller implementierte Pakete oder Ähnliches. Es ist nicht möglich, solche Pakete zu deinstallieren, und um solche Geräte zu verarbeiten, können Pakete auf eine Whitelist gesetzt werden. Wenn ein Paket auf der Whitelist steht, schlägt der Löschvorgang nicht fehl, wenn die Deinstallation des Pakets fehlschlägt. 

Wenn Pakete auf der Whitelist stehen (und die Löschung nicht fehlschlägt, auch wenn die Deinstallation nicht erfolgreich ist), kann Blancco nicht garantieren, dass die Löschung vollständig erfolgreich ist. 

Standardmäßig können nur Benutzer mit Admin-Zugang zur BMDE-Station Pakete in die Whitelist aufnehmen. Die aktuell auf der Whitelist stehenden Pakete können unter "Einstellungen" → "Android"-Registerkarte eingesehen werden.

Lösung

Es gibt zwei Möglichkeiten, dieses Problem zu lösen:

  1. Durch das Zurücksetzen auf die Werkseinstellungen zu Beginn des Prozesses können möglicherweise einige der problematischen Pakete erfolgreich entfernt werden. In diesem Fall kann das Gerät nach dem Zurücksetzen auf die Werkseinstellungen normal gelöscht werden, und dem Bericht wird keine Informationsmeldung hinzugefügt, die sich auf die Pakete auf der Whitelist bezieht. Beachten Sie, dass der Benutzer nach dem Zurücksetzen des Geräts auf die Werkseinstellungen das Gerät neu einrichten muss, um das USB-Debugging zu aktivieren..
  2. Wenn Option 1 nicht erfolgreich ist, um solche Pakete zu entfernen, besteht die einzige Möglichkeit darin, sie in die Whitelist aufzunehmen

Die Durchführung des Werksresets kann in bestehende Workflows eingebaut werden, so dass der Benutzer bedingte Anweisungen definieren kann, bei denen der zusätzliche Werksreset nur bei Bedarf und nicht für alle Geräte ausgeführt wird. Alternativ kann eine globale Einstellung aktiviert werden, um den Werksreset immer zu Beginn eines Löschvorgangs auszuführen. Diese Einstellung ist unter "Einstellungen" → "Android" → "Werksreset immer zu Beginn des Löschvorgangs ausführen" verfügbar, wie im folgenden Screenshot gezeigt.